# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\b(?!process)\w*EventHandler)\(([^)]*)\)/processEventHandler($1, $2)/gim;t' <<< "loginEventHandler(err, result)
processEventHandler(loginEventHandler, err, result)
eventHandler(err, result)
appInitEventHandler(err, result)
initProcessEventHandler(err, result)
initprocessEventHandler(err, result)
generic(e, r)"