# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\b(?!process)\w*EventHandler)\(([^)]*)\)"
test_str = ("loginEventHandler(err, result)\n"
"processEventHandler(loginEventHandler, err, result)\n"
"eventHandler(err, result)\n"
"appInitEventHandler(err, result)\n"
"initProcessEventHandler(err, result)\n"
"initprocessEventHandler(err, result)\n"
"generic(e, r)")
subst = "processEventHandler($1, $2)"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE | re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.