#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im)(\b(?!process)\w*EventHandler)\(([^)]*)\)"
Local $sString = "loginEventHandler(err, result)" & @CRLF & _
"processEventHandler(loginEventHandler, err, result)" & @CRLF & _
"eventHandler(err, result)" & @CRLF & _
"appInitEventHandler(err, result)" & @CRLF & _
"initProcessEventHandler(err, result)" & @CRLF & _
"initprocessEventHandler(err, result)" & @CRLF & _
"generic(e, r)"
Local $sSubst = "processEventHandler($1, $2)"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)