use strict;
my $str = 'loginEventHandler(err, result)
processEventHandler(loginEventHandler, err, result)
eventHandler(err, result)
appInitEventHandler(err, result)
initProcessEventHandler(err, result)
initprocessEventHandler(err, result)
generic(e, r)';
my $regex = qr/(\b(?!process)\w*EventHandler)\(([^)]*)\)/imp;
my $subst = 'processEventHandler($1, $2)';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";