using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\b(?!process)\w*EventHandler)\(([^)]*)\)";
string substitution = @"processEventHandler($1, $2)";
string input = @"loginEventHandler(err, result)
processEventHandler(loginEventHandler, err, result)
eventHandler(err, result)
appInitEventHandler(err, result)
initProcessEventHandler(err, result)
initprocessEventHandler(err, result)
generic(e, r)";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}