import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\b(?!process)\\w*EventHandler)\\(([^)]*)\\)";
final String string = "loginEventHandler(err, result)\n"
+ "processEventHandler(loginEventHandler, err, result)\n"
+ "eventHandler(err, result)\n"
+ "appInitEventHandler(err, result)\n"
+ "initProcessEventHandler(err, result)\n"
+ "initprocessEventHandler(err, result)\n"
+ "generic(e, r)";
final String subst = "processEventHandler($1, $2)";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}