$re = '/(\b(?!process)\w*EventHandler)\(([^)]*)\)/im';
$str = 'loginEventHandler(err, result)
processEventHandler(loginEventHandler, err, result)
eventHandler(err, result)
appInitEventHandler(err, result)
initProcessEventHandler(err, result)
initprocessEventHandler(err, result)
generic(e, r)';
$subst = "processEventHandler($1, $2)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;