const regex = /(\b(?!process)\w*EventHandler)\(([^)]*)\)/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\b(?!process)\\w*EventHandler)\\(([^)]*)\\)', 'gim')
const str = `loginEventHandler(err, result)
processEventHandler(loginEventHandler, err, result)
eventHandler(err, result)
appInitEventHandler(err, result)
initProcessEventHandler(err, result)
initprocessEventHandler(err, result)
generic(e, r)`;
const subst = `processEventHandler($1, $2)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);