import Foundation
let pattern = #"(\b(?!process)\w*EventHandler)\(([^)]*)\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
loginEventHandler(err, result)
processEventHandler(loginEventHandler, err, result)
eventHandler(err, result)
appInitEventHandler(err, result)
initProcessEventHandler(err, result)
initprocessEventHandler(err, result)
generic(e, r)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"processEventHandler($1, $2)"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)