#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ""(?U)\\b[\\p{Upper}\\p{Space}\\p{Punct}]{2,}\\b""
Local $sString = "I HATE YOU;" & @CRLF & _
"1, 2, 3, GO!" & @CRLF & _
"ÄMLÄTS!" & @CRLF & _
"ZOMG THE %^*@#$(*^ ZOMBIES ARE COMING!!11!!1!" & @CRLF & _
"ÄMLäTS!"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")