$re = '/"(?U)\\\\b[\\\\p{Upper}\\\\p{Space}\\\\p{Punct}]{2,}\\\\b"/';
$str = 'I HATE YOU;
1, 2, 3, GO!
ÄMLÄTS!
ZOMG THE %^*@#$(*^ ZOMBIES ARE COMING!!11!!1!
ÄMLäTS!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);