use strict;
my $str = 'I HATE YOU;
1, 2, 3, GO!
ÄMLÄTS!
ZOMG THE %^*@#$(*^ ZOMBIES ARE COMING!!11!!1!
ÄMLäTS!';
my $regex = qr/"(?U)\\b[\\p{Upper}\\p{Space}\\p{Punct}]{2,}\\b"/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}