import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"(?U)\\\\b[\\\\p{Upper}\\\\p{Space}\\\\p{Punct}]{2,}\\\\b\"";
final String string = "I HATE YOU;\n"
+ "1, 2, 3, GO!\n"
+ "ÄMLÄTS!\n"
+ "ZOMG THE %^*@#$(*^ ZOMBIES ARE COMING!!11!!1!\n"
+ "ÄMLäTS!";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}