import re
regex = re.compile(r"\"(?U)\\b[\\p{Upper}\\p{Space}\\p{Punct}]{2,}\\b\"")
test_str = ("I HATE YOU;\n"
"1, 2, 3, GO!\n"
"ÄMLÄTS!\n"
"ZOMG THE %^*@#$(*^ ZOMBIES ARE COMING!!11!!1!\n"
"ÄMLäTS!")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")