using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""(?U)\\b[\\p{Upper}\\p{Space}\\p{Punct}]{2,}\\b""";
string input = @"I HATE YOU;
1, 2, 3, GO!
ÄMLÄTS!
ZOMG THE %^*@#$(*^ ZOMBIES ARE COMING!!11!!1!
ÄMLäTS!";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}