re = /"(?U)\\b[\\p{Upper}\\p{Space}\\p{Punct}]{2,}\\b"/
str = 'I HATE YOU;
1, 2, 3, GO!
ÄMLÄTS!
ZOMG THE %^*@#$(*^ ZOMBIES ARE COMING!!11!!1!
ÄMLäTS!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end