# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^\s*^\\/\\/###==###.*?\\/\\/###==###\s*)//gms;t' <<< "Text to keep
//###==###
Text to remove
//###==###
Text to keep"