#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?ms)(^\s*^\/\/###==###.*?\/\/###==###\s*)"
Local $sString = "Text to keep" & @CRLF & _
"" & @CRLF & _
"//###==###" & @CRLF & _
"Text to remove" & @CRLF & _
"//###==###" & @CRLF & _
"" & @CRLF & _
"Text to keep"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)