const regex = /(^\s*^\/\/###==###.*?\/\/###==###\s*)/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^\\s*^\\\/\\\/###==###.*?\\\/\\\/###==###\\s*)', 'gms')
const str = `Text to keep
//###==###
Text to remove
//###==###
Text to keep`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);