using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^\s*^\/\/###==###.*?\/\/###==###\s*)";
string substitution = @"";
string input = @"Text to keep
//###==###
Text to remove
//###==###
Text to keep";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}