package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)(^\s*^\/\/###==###.*?\/\/###==###\s*)`)
var str = `Text to keep
//###==###
Text to remove
//###==###
Text to keep`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}