import re
regex = re.compile(r"(^\s*^\/\/###==###.*?\/\/###==###\s*)", flags=re.MULTILINE | re.DOTALL)
test_str = ("Text to keep\n\n"
"//###==###\n"
"Text to remove\n"
"//###==###\n\n"
"Text to keep")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)