re = /(^\s*^\/\/###==###.*?\/\/###==###\s*)/m
str = 'Text to keep
//###==###
Text to remove
//###==###
Text to keep'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result