// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ms)(^\s*^\/\/###==###.*?\/\/###==###\s*)").unwrap();
let string = "Text to keep
//###==###
Text to remove
//###==###
Text to keep";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}