# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\{[^\}]*\}/,/g;t' <<< "
.class1 {
border-width: 10px;
color: #FFFFFF;
}
.class 2 {
background-color: #445566;
}
"