const regex = /\{[^\}]*\}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\{[^\\}]*\\}', 'g')
const str = `
.class1 {
border-width: 10px;
color: #FFFFFF;
}
.class 2 {
background-color: #445566;
}
`;
const subst = `,`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);