re = /\{[^\}]*\}/
str = '
.class1 {
border-width: 10px;
color: #FFFFFF;
}
.class 2 {
background-color: #445566;
}
'
subst = ','
result = str.gsub(re, subst)
# Print the result of the substitution
puts result