use strict;
my $str = '
.class1 {
border-width: 10px;
color: #FFFFFF;
}
.class 2 {
background-color: #445566;
}
';
my $regex = qr/\{[^\}]*\}/p;
my $subst = ',';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";