# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\{[^\}]*\}"
test_str = ("\n"
".class1 {\n"
" border-width: 10px;\n"
" color: #FFFFFF;\n"
"}\n\n"
".class 2 {\n"
" background-color: #445566;\n"
"}\n")
subst = ","
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.