import Foundation
let pattern = #"\{[^\}]*\}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
.class1 {
border-width: 10px;
color: #FFFFFF;
}
.class 2 {
background-color: #445566;
}
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #","#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)