$re = '/\{[^\}]*\}/';
$str = '
.class1 {
border-width: 10px;
color: #FFFFFF;
}
.class 2 {
background-color: #445566;
}
';
$subst = ",";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;