import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "r\"[\\d]{9}\"";
final String string = "\"string\": \"Example phrasing:\",\n"
+ " \"create-email\": \"dadowns1159@gmail.com\",\n"
+ " \"create-time\": 1602417978844,\n"
+ " \"children\": [\n\n\n"
+ "this: \"example: value\"\n"
+ "that: \"random: value\"\n"
+ " 789654123";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}