// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
  let regex = Regex::new(r#"(?mi)r"[\d]{9}""#).unwrap();
  let string = "\"string\": \"Example phrasing:\",
                        \"create-email\": \"dadowns1159@gmail.com\",
                        \"create-time\": 1602417978844,
                        \"children\": [
this: \"example: value\"
that: \"random: value\"
 789654123";
  
  // result will be a tuple containing the start and end indices for the first match in the string
  let result = regex.captures(string);
  
  let (start, end) = match result {
    Some((s, e)) => (s, e),
    None => {
        // ...
    }
  };
  
  
  println!("{}", &string[start, end]);
}