import re
regex = re.compile(r"r\"[\d]{9}\"", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("\"string\": \"Example phrasing:\",\n"
" \"create-email\": \"dadowns1159@gmail.com\",\n"
" \"create-time\": 1602417978844,\n"
" \"children\": [\n\n\n"
"this: \"example: value\"\n"
"that: \"random: value\"\n"
" 789654123")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")