use strict;
my $str = '"string": "Example phrasing:",
"create-email": "dadowns1159@gmail.com",
"create-time": 1602417978844,
"children": [
this: "example: value"
that: "random: value"
789654123';
my $regex = qr/r"[\d]{9}"/mip;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}