import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[blargh=(?|\"(\\d+)\"|(\"[^\"]*\"))\\]";
final String string = "[blargh=\"5\"] [blargh=\"97\"] [blargh=\"StackOverflow\"]\n";
final String subst = "<potato chips=#\\1#>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}