import Foundation
let pattern = #"\[blargh=(?|"(\d+)"|("[^"]*"))\]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
[blargh="5"] [blargh="97"] [blargh="StackOverflow"]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = ##"<potato chips=#\1#>"##
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)