use strict;
my $str = '[blargh="5"] [blargh="97"] [blargh="StackOverflow"]
';
my $regex = qr/\[blargh=(?|"(\d+)"|("[^"]*"))\]/mp;
my $subst = '<potato chips=#\\1#>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";