// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\[blargh=(?|"(\d+)"|("[^"]*"))\]"#).unwrap();
let string = "[blargh=\"5\"] [blargh=\"97\"] [blargh=\"StackOverflow\"]
";
let substitution = "<potato chips=#\\1#>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}