$re = '/\[blargh=(?|"(\d+)"|("[^"]*"))\]/m';
$str = '[blargh="5"] [blargh="97"] [blargh="StackOverflow"]
';
$subst = "<potato chips=#\1#>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;