import re
regex = re.compile(r"\[blargh=(?|\"(\d+)\"|(\"[^\"]*\"))\]", flags=re.MULTILINE)
test_str = ("[blargh=\"5\"] [blargh=\"97\"] [blargh=\"StackOverflow\"]\n")
subst = "<potato chips=#\\1#>"
result = regex.sub(subst, test_str)
if result:
print(result)