const regex = /"[^"]*"(*SKIP)(*F)|Dog/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"[^"]*"(*SKIP)(*F)|Dog', 'gi')
const str = `Dogs are scary but my mom told me that "Dogs are cute"`;
const subst = `Cat`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);