// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)"[^"]*"(*SKIP)(*F)|Dog"#).unwrap();
let string = "Dogs are scary but my mom told me that \"Dogs are cute\"";
let substitution = "Cat";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}