use strict;
my $str = 'Dogs are scary but my mom told me that "Dogs are cute"';
my $regex = qr/"[^"]*"(*SKIP)(*F)|Dog/ip;
my $subst = 'Cat';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";