$re = '/"[^"]*"(*SKIP)(*F)|Dog/i';
$str = 'Dogs are scary but my mom told me that "Dogs are cute"';
$subst = "Cat";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;