import re
regex = re.compile(r"\"[^\"]*\"(*SKIP)(*F)|Dog", flags=re.IGNORECASE)
test_str = "Dogs are scary but my mom told me that \"Dogs are cute\""
subst = "Cat"
result = regex.sub(subst, test_str)
if result:
print(result)