#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ism)<!--\sLOCALE\sru\s-->(.*?)<!--\s\/LOCALE\s-->"
Local $sString = "<!-- LOCALE uk -->" & @CRLF & _
" <h2 class="">Required Information UK</h2>" & @CRLF & _
" <!-- /LOCALE -->" & @CRLF & _
"<!-- LOCALE uk --><h2 class="">Required Information UK</h2><!-- /LOCALE -->" & @CRLF & _
"<!-- LOCALE ru -->" & @CRLF & _
"<h2 class="">Required Information RU</h2>" & @CRLF & _
"<!-- /LOCALE -->"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")