const regex = /<!--\sLOCALE\sru\s-->(.*?)<!--\s\/LOCALE\s-->/ism;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<!--\\sLOCALE\\sru\\s-->(.*?)<!--\\s\\\/LOCALE\\s-->', 'ism')
const str = `<!-- LOCALE uk -->
<h2 class="">Required Information UK</h2>
<!-- /LOCALE -->
<!-- LOCALE uk --><h2 class="">Required Information UK</h2><!-- /LOCALE -->
<!-- LOCALE ru -->
<h2 class="">Required Information RU</h2>
<!-- /LOCALE -->`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}