import Foundation
let pattern = #"<!--\sLOCALE\sru\s-->(.*?)<!--\s\/LOCALE\s-->"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive, .dotMatchesLineSeparators])
let testString = #"""
<!-- LOCALE uk -->
<h2 class="">Required Information UK</h2>
<!-- /LOCALE -->
<!-- LOCALE uk --><h2 class="">Required Information UK</h2><!-- /LOCALE -->
<!-- LOCALE ru -->
<h2 class="">Required Information RU</h2>
<!-- /LOCALE -->
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}