import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<!--\\sLOCALE\\sru\\s-->(.*?)<!--\\s\\/LOCALE\\s-->";
final String string = "<!-- LOCALE uk -->\n"
+ " <h2 class=\"\">Required Information UK</h2>\n"
+ " <!-- /LOCALE -->\n"
+ "<!-- LOCALE uk --><h2 class=\"\">Required Information UK</h2><!-- /LOCALE -->\n"
+ "<!-- LOCALE ru -->\n"
+ "<h2 class=\"\">Required Information RU</h2>\n"
+ "<!-- /LOCALE -->";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.DOTALL | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}